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NORTHWESTERN UNIVERSITY 
Department of Electrical and Computer Engineering 

 

ECE-221 Fundamentals of Circuits 
 

Lab 1: Introduction to HP VEE and PSPICE 
 
 

Quick Start to HP VEE - Visual Programming  
 
What is HP VEE?  
 HP VEE is a programming language (a.k.a., graphical programming language) optimized for 
building test and measurement applications - especially programs with operator interface. 
 
The Development Environment Components  

• The Menu Bar provides menus holding the commands and icons used to build your programs. 
• The Tool Bar displays buttons as shortcuts to the most common tasks in HP VEE.  (Just place 

the mouse pointer over a button and HP VEE displays the button's function.) 
• The Program Explorer displays the program's hierarchy of functions. 
• The Work Area is where you construct your program with icons.  This is simply a window 

displayed by default.  As you program various functions, they will each have their own 
window.  Multiple windows can be seen at once (Multiple Document Interface).  You can use 
the Program Explorer to easily navigate between these various windows. 

• The Status Bar will explain the object or menu selection you are highlighting as well as give 
you information on the programming compatibility mode you are in - STD, VEE 4, or VEE 3 
for example. 

 
For more information on how to use HP VEE, refer to Appendix A. 
 
For a review of the instrumentation, refer to Appendix B. 
 
 

HP VEE Tutorial 
 

 
Generating a triangle wave 

• Turn on the function generator and the oscilloscope 
• Connect the function generator to channel 1 of the oscilloscope using a coax cable 
• Open HP VEE on your computer 
• Place the function generator panel control in the work area 

o Open I/O->Instrument Manager… 
o Select the function generator 
o Click on the Panel Driver button 
o Click on the work area to place the control 

• Select the Main Panel 
o Click on the blue button at the top of the control 
o Select Main Panel from the list 

• Set the function to triangle 
o Click on the function type and select triangle 

• Set Frequency to 1KHz 
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• Set the Amplitude to 3 volts 
• Set the DC Offset to 1 volt 
• You should now see a triangle wave on the oscilloscope with a frequency of 1KHz, amplitude of 

3V, and DC offset of 1V 
 
Frequency sweep 
The function generator you will be using is capable of doing what’s called a frequency sweep.  You will be 
able to observe the behavior of a curve displayed on the oscilloscope as its frequency changes over a certain 
range.  This will become very useful later on in the course, as you will start learning about the frequency 
domain. 
 

• On the panel control of the function generator in your HP VEE work area make the following 
modifications 

• Change the function type to sine 
• Set the Frequency to 100Hz 
• Set the Amplitude to 1V 
• Set the DC Offset to 0 
• Click on the blue button currently displaying Main Panel and change it to Sweep Panel 
• Set the Start Swp Frequency to 100Hz 
• Set the Stop Swp Frequency to 1KHz 
• Set Swp Time to 1 
• Now click on the Swp State button currently displaying OFF 
• You now see the sine curve on your oscilloscope smoothly change frequency from 100Hz to 

1KHz, then from 1KHz back to 100Hz, etc. 
 
Oscilloscope Data Acquisition 
In addition to controlling the instruments through your desktop, you can read and save data produced by the 
oscilloscope.  The application that allows your acquire data is HP Scope Control Sample Application.  
The acquired data can later be imported into another application for plotting and analysis.   
 
Superposition of sine curves 
 

• In HP VEE, have the function generator produce a sine curve 
o Frequency – 500Hz 
o Amplitude – 1V 
o DC Offset – 0 

• Switch to HP Scope Control Application 
• From the Instrument menu select Get All Waveform Data 

o This should produce a green curve on your screen 
• Save this wave as a text (*.txt) file 

o File->Save As 
o Set Save as Type to Text File (*.txt) 

• Repeat the same steps for another sine curve 
o Frequency – 1KHz 
o Amplitude – 0.5V 
o DC Offset – 0 

• NOTE: Do not change the view of the oscilloscope when displaying the second curve.  Changing 
the view will cause the data to be acquired over a different range.  By changing the range, you will 
also change the interval between data points, thus making the two data sets harder to manipulate. 

• Open the two saved files in Excel and display the data side by side 
o When prompted for the delimiter select space 
o Remove all unnecessary information from the worksheet 
o Column positions may need to be adjusted 
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• In Excel, add the two data columns and plot it over the period of time specified in the first column.  
Refer to Appendix C for more information on how to manipulate and plot data in MS Excel. 

PSpice Tutorial 
What is PSpice? 

PSpice is also a graphical programming language that allows one to build and test circuits  
theoretically by building a schematic using predefined parts.  It works using nodal analysis and can perform 
voltage and frequency sweeps, calculate transfer functions, evaluate temperature characteristics, and much 
more. 
 
History 
 PSpice used to be a text-based program in which one had to assign nodes to a circuit on paper and 
use a special format to enter a program to run.  For example, a resistor would be modeled as: 
R1 1 0 10K = Resistor 1_Positive Side_Negative Side_Value.  Programs generally follow the format of: 
 
TITLE 
*comments 
code 
.commands 
END 
 
Now the schematic is a much more easy way to model circuits in PSpice though not all components one 
wants to use may be represented.  One must then program his or her own component using this language. 
 
The Development Environment Components  

• The Menu Bar provides menus holding the commands and icons used to build your programs. 
• The Tool Bar displays buttons as shortcuts to the most common tasks in PSpice.  (Just place the 

mouse pointer over a button and HP VEE displays the button's function.) 
• The Work Area is where you construct your circuit with icons from the new parts menu.  This is 

simply a window displayed by default.  
 
Getting Started 

• Open PSpice Schematics by clicking Start, Programs, PSpice Student, Schematics. 
• Click the “Get New Part” (binoculars) button for a list of components.  The most common are: 

o r = Resistor 
o c = Capacitor 
o l = Inductor 
o VDC and VAC = Direct current and alternating current independent voltage sources 
o IDC and IAC = Direct current and alternating current independent current sources 
o E = Voltage controlled dependent voltage source 
o F = Current controlled dependent current source 
o G = Voltage controlled dependent current source 
o H = Current controlled dependent voltage source 
o GND_EARTH = Ground 
o Sw_tOPEN and Sw_tClose = Switches that open or close at a certain time 

• For voltage and current probes, click on the respective buttons to the far right in the Tool Bar and 
place them in contact with a point where you want to measure. 

• To wire together components, click the “Wire” button then click once on the first component, drag 
the wire, then click again on the second component.  Clicking in between components pins the wire 
down to allow for parts not in line with one another. 

• In order to change values of components, double click on the value next to the component and 
enter a new value.  To simplify the entering of numbers: 

o F = 10-15 
o P = 10-12 
o N = 10-9 
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o U = 10-6 
o M = 10-3 
o K = 103 
o MEG = 106 
o G = 109 
o T = 1012 
o E = *10x 

For example, 1K = 1000 and 3E5 = 300,000 
• To rotate a component, first click on it to select it, then type Ctrl-R. 
• To specify which operations to perform, click the “Setup Analysis” button and choose which 

operations to perform with the checkboxes.  Clicking on the names of operations allows for setting 
parameters. 

• To run the analysis, click on “Simulate.” 
 
Basic Circuit 
 

• Click “Get New Part” and select VDC.  Place the source onto the schematic. 
• Click “Get New Part” and select r.  Place three resistors onto the schematic. 
• Wire the components together as shown. 
• Double click on the values of each component and reassign the appropriate values. 
• Click “Current Marker” and connect it to the wire to the 1.2 kΩ resistor. 
• Click “Setup Analysis,” DC Sweep, and enter the name of the voltage source (ie V1), a start value, 

an end value and an increment. 
• Click OK and make sure that DC Sweep is selected.  Close that window. 
• Click on “Simulate.”  A new window should open with a graph of the current through the 1.2 kΩ 

resistor vs. the input voltage. 
 
Frequency Sweep 

• Compose and AC frequency sweep the following circuit with Vs = 5 V, L = 1mH, R = 500 Ω, and 
C = 0.1 µF, from 1Hz to 1GHz with 100 steps per decade. 

 
 
 
 
 
 

1 kΩ 1.2 kΩ 1.5 kΩ
1.5 V

+

 _
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Appendix A: Using HP VEE 
 

Using Menus 
1. Click and hold Device to open the menu.  A pull-down menu appears. 
2. Move the mouse pointer down the Virtual Source submenu, then right to Function 

Generator, and then release the mouse button. 
3. Move the Function Generator to the center of the work area, and click to place the 

object. 
4. Now open the Function Generator object men-u by clicking the horizontal bar in the 

upper left-hand corner of the object. 
 
Saving Your Work, Exiting HP VEE, and Re-starting Your Program 

To Save Your Work and Exit HP VEE  
1. Select File => Save As ...  and complete the dialog box. 
2. Select File => Exit to close the HP VEE application window. 

Shortcut: Press Ctrl-E to exit HP VEE. 
To Re-start UP VEE and Run Your Program  
1. PC: In Windows95 or Windows NT 4.0 or greater, click Start, moves to the HP VEE 5.0 

submenu, and select HP VEE. 
2. Select File => Open and complete the Open File dialog box. 
3. Click the Run button - which looks like a small arrowhead - on the tool bar (below the 

Debug menu). 
 
Helping Yourself  

• Click Help in an object menu to get specific information on that object. 
• Click Help on the main menu bar to access the online help facility for HP VEE, which will 

give information on contents and index, instrument drivers, HP VEE on the web, program 
examples, and revision. 

• Use the Help system to search for HP VEE topics you need to locate.  The Help system can 
also "jump" to related subjects. 

• You could learn HP VEE entirely online through experimentation and consulting the Help 
system. 

 
Using Objects 

To Delete an Object from the Work Area 
1. Place the mouse cursor over the object menu and double-click. 

- OR - 
Open the object menu, and select Cut. 

- OR - 
Select the object (click on it) and press Ctrl-X. 

To Paste a Deleted Object 
(To "Undo" a Cut) 
1. After an object has been deleted, click Edit => Paste.  An outline of the object appears.  

Place the object and click to release it. 
- OR - 

Press Ctrl-V. 
To Copy an Object 
1. Click on an object to highlight it, then click Edit => Copy. 

- OR - 
Click on an object to highlight it, the press Ctrl-C. 

To Duplicate (or Clone) an Object 
1. Open the object menu and select Clone. 

An outline of the duplicated object appears. 
2. Move the outline to the desired location, and click to place the object. 
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To Move an Object 
1. Open the object menu and select Move. 

The object is highlighted. 
2. Place the mouse pointer over the object, press and hold the left mouse button (called 

"dragging"), while you move the object to the desired location. 
3. Release to place the object. 

Shortcut: You can also click and drag the object. 
To Edit the Name of an Object 
1. Open the object menu and select Properties... 

A Properties dialog box appears with the current title highlighted. 
2. Type the new title and click OK 

- OR - 
1. Double-click the object title bar to go directly to the Properties dialog box. 
2. Type in the new title and click OK. 
To Switch an Object Between Iconic and Open Views 
1. To switch from an open to iconic view, click the dot on the right end of the object's title 

bar.  To return to an open view, double-click the icon. 
To Size an Object 
1. Place the mouse pointer over the lower right-hand corner of the object until you see a 

right-angle, then click-and-drag to the desired position. 
- OR - 

Open the object menu and click Size.  You will see a small right angle on the cursor. 
2. Move the right angle to desired position of the lower-right corner and click. 
To Select or Deselect an Object 
1. An object is selected when you click it.  HP VEE puts a shadow behind it.  To deselect it, 

just move the mouse pointer over any open area and click. 
To Select Several Objects 
1. Press Ctrl, then click-and-drag a rectangle around the objects to be selected. 
To Select/Deselect All Objects 
1. To select all objects, click Edit => Select All.  (Or press Ctrl-A.) 
2. To deselect them, click on an open area in the window. 
To Edit Objects 
1. Click Edit on the menu bar and select the operation you want. 

- OR - 
Place the mouse pointer anywhere on blank work area space and click the right mouse 
button. 
A pop-up Edit menu appears. 

To Create Data Lines Between Objects 
1. Click on or just outside the data output pin of one object, the click on the data input pin of 

another.  (A line appears behind the pointer as you move from one pin to the other.) 
To Move the Work Area 
1. (Make sure there is at least one icon in the work area.) Place the mouse pointer anywhere 

on the background of the work area, press and hold the left mouse button, and move the 
work area in any direction. 

To Clear the Work Area 
1. Select File => New. 
To Delete Lines 
1. Press Shift-Ctrl and click the line you want to delete.  Or select Edit => Delete Line and 

click the line you want to delete. 
 

Object Pins and Terminals 
To Add Data Input Terminals to an Object 
1. Open the object menu and select Add Terminal => Data Input 

Shortcut: Just place the mouse pointer over the terminal input area and press CTRL-A. 
To Delete Data Input or Output Terminals from an Object 
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1. Open the object menu and select Delete Terminal => Input....  choose the input to 
delete, and click OK. 
Shortcut: Just place the mouse pointer over the terminal and press CTRL-D. 

To Examine or Alter Terminals 
1. Double-click on the terminal.  Change any of the fields, if appropriate, then click OK. 

You can also check the data type this way. 
To Edit the Terminal Name 
1. Double-click the terminal.  The Name input field is highlighted. 
2. Type the new name and click OK. 

 
(The above was taken directly out of Helsel, Robert - Hewlett-Packard Company.  Visual Programming 
with HP VEE, 3rd ed.  New Jersey: Prentice Hall PTR, 1998.) 
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Appendix B: Instruments 
 

HP 33120A Function Generator / Arbitrary Waveform Generator 
 
Introduction 
The HP 33120A is a high-performance 15 MHz synthesized function generator with built-in arbitrary 
waveform capability.  It uses direct digital-synthesis techniques to create a stable, accurate output signal for 
clean, low-distortion sine waves.  It also gives you fast rise and fall-time square wave, and linear ramp 
waveforms down to 10 mHz and up to 15 MHz in most cases.  Other standard waveforms you can generate 
easily with this state-of-the-art equipment includes triangle, noise, sin(x)/x (or Sinc function), exponential 
rise and fall, cardiac, and dc volts.  One of the most important features that comes with this equipment is its 
four downloadable 16,000-point arbitrary waveform memories, which means you can create user defined 
arbitrary waveforms and download it onto the non-volatile memory of the function generator for late use.  
This is an extremely versatile feature that allows for almost endless possibilities of waveforms this 
equipment can generate.  One other feature worth mentioning is that this function generator has built-in 
standard HP-IB and RS-232 interfaces, this allows it to be connected to other compatible HP testing 
equipment and to a work station equipped with an interface card, this way the operation of this equipment 
can be remotely controlled by the work station.  We will demonstrate this capability using HP VEE a little 
bit later. 
 
Getting to know the equipment 
Now familiarize yourself with the front panel of the function generator, although all those keys on there 
could seem a little confusing, but they are actually organized into 4 groups. 
(1) The Function / Modulation keys.  These are the first 6 keys from the left on the top row, they represent 

all the standard waveforms you can generate as well as any possible arbitrary waveforms users have 
defined.  These buttons will be the first step in generating a desired waveform. 

(2) The Waveform Modify keys.  They are located directly below the Function / Modulation keys on the 
left side of the bottom row.  They are used to set and modify specifications of the generated waveform, 
such as frequency and amplitude. 

(3) The Enter Number unit keys.  These include the two columns of keys directly to the left of the output 
terminals near the right edge of the front panel, and the big round knob above those columns.  These 
are used to enter numbers into the function generator such as when setting the frequency for a sine 
wave.  There are three basic ways you can enter a number into the equipment, sometimes it is easier use 
one instead of another, but generally which way you choose is mostly up to your preference. 

Method 1:  Use the arrow keys to edit individual digits.  Use the left or right arrows to move the 
highlighted digit to the left or right, then use up or down arrows to increase or decrease the value of the 
highlighted digit. 

Method 2:  Use the arrow keys and the knob.  Use the left right arrows to move the highlighted 
digit as before, but instead of using the up or down arrows, use the knob to increase or decrease the value of 
the highlighted digit. 

Method 3:  Use the "Enter Number" mode.  If you observe carefully, you will see that many of the 
keys on the front panel has a single digit number to their left, you can enter a number directly using these 
keys.  First push the "Enter Number" key which is directly below the "Arb" key, then enter the desired 
number using the numeric keys, then either press "Enter" or one of the four arrow keys which each represent 
a unit of measurement printed to its right.  To cancel anytime in this process, just press "Shift- Cancel". 
(4) The Miscellaneous keys.  There are a few more keys on the second row between the Modify keys and 

the Enter Number keys, they are used for some miscellaneous purposes such as storing a current state, 
etc. 

 
Examples 
Now you have familiarized yourself with the front panel, let's do some simple examples. 
(1) Generating a sine wave. 

Step 1:  Turn on the function generator; the power button is near the left most edge of the front 
panel. 
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Step 2:  After the generator has completed its start up self-test, press the "sine" key which is 
marked by a little sine wave. 

Step 3:  Enter the desired frequency by first pressing the "Freq" key, then use one of the three 
above methods to enter a frequency of 10 kHz.  If the "Enter Number" mode is on, the words "Num" will 
flash on the screen.  Note: You can change the units by highlighting it first using the left or right arrows, 
then use either the knob or the up and down arrows key to cycle through the available units. 

Step 4:  Enter the amplitude by first pressing the "Ampl" key, and then enter an amplitude of 5 
volts using again one of the three methods described above. 
Now you should have a sine wave with frequency of 10 kHz and amplitude of 5 volts. 
 
Exercise: Change the frequency of this sine wave to 500 Hz, and amplitude to 500 mV. 
Exercise: Generate a square wave with frequency 2.5 MHz and amplitude of 65000 µV using two different 
methods. 
Bonus: Set the duty cycle for this square wave to 60%.  Note: for square wave, duty cycle can go from 20% 
- 80%. 
 
(2) Generating a DC offset voltage. 

Step 1:  Press the "Offset" key. 
Step 2:  Enter a magnitude of - 1.5 volts.  Note: If the "Enter Number" mode is enabled, press the 

"+-" key to toggle the value between positive and negative. 
(3) Output a stored arbitrary waveform. 
There are five built in arbitrary waveforms (sinc, negative ramp, exponential rise, exponential fall, and 
cardiac).  The list may also contain up to four user defined arbitrary waveform names. 

Step 1: Press the "Shift and Arb" keys, which will bring up the arbitrary waveform list. 
Step 2: The first choice on the list is sinc, to see the other members of the list, either use the knob 

or the left and right arrow keys to cycle through the choices.  Now go back to sinc, and press "Enter".  Note 
the "Arb" indicator turns on. 

Step 3: Now give this waveform a frequency of 20 kHz and an amplitude of 5 volts as before. 
 
Exercise: Display the other four built in waveforms in order, adjust frequency or amplitude as desired so 
you can see what they all look like. 
 
(4) To store and recall an instrument state. 
You can store up to three different instrument states in non-volatile memory.  This enables you to recall the 
entire instrument configuration with just a few key presses from the front panel, even after the instrument 
has been turned off. 

Step 1: Create a Triangle waveform with frequency 1 kHz and amplitude 3 volts. 
Step 2: Press the "Shift-Store" keys to turn on the state storage mode.  Three memory locations 

(numbered 1, 2, and 3) are available to store instrument configurations.  Right now "STORE 1" should be 
on the screen representing memory location 1, it will remain there for 10 seconds, repeat this step as 
needed.  Use the up and down arrows to select memory location 2. 

Step 3: Press "Enter" to store current state to memory location 2. 
To recall a previously stored state, first change the configuration of the current state by generating a sine 
wave. 

Step 4: Press the "Recall" key. 
Step 5: Use up and down arrow to select the correct memory location, in this case, memory 

location 2. 
Step 6: Press "Enter" key to recall the state. 

 
An HP VEE Example 
As mentioned above, HP 33120A is capable of being controlled remotely by a computer; many complicated 
tasks can be significantly simplified using the computer interface.  Assuming you have read the section on 
HP VEE, we will now go through a quick example of controlling the function generator using HP VEE.  In 
this example, we will generate a frequency sweep; this is useful to determine the frequency response of a 
system. 
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Step l:  Start HP VEE, place the HP33120A instrument panel driver in the working area by going 
to I/0 -> Instrument Manager. 

Step 2:  In the panel driver object, to the right of the "Reset" button, there should be a dialog box 
with the name of the current panel name.  Right now, it should be "Main Panel".  From this panel, you can 
select the appropriate waveform to be swept and set other attributes for this waveform as desired.  For this 
example, select the sinusoidal wave with amplitude of 1 volt.  Note: To change an attribute, just left click on 
the corresponding dialog box, select or type the desired value, then select "OK". 

Step 3:  Left click on dialog box with the words "Main Panel", from the pop up window, highlight 
"Sweep Panel", and then click on "OK".  Notice the dialog box now says "Sweep Panel" and the controls on 
the panel have now changed to the appropriate sweep controls. 

Step 4:  Set the "Swp Start" to 1000 Hz, this is the frequency where the sweeping will start from.  
Set "Swp Stop" to 100 kHz, this is the frequency where the sweeping will end.  Together, they define the 
range of the sweep.  Leave the rest of the attributes alone.  "Swp Time" should be 1, "Spacing" should be 
linear, "TrigSource" should be immediate. 

Step 5:  Click on the "Swp State" box to toggle it on, now the function generator should start 
sweeping from 1 kHz to 100 kHz continuously, then back to 1 kHz to start over. 

Step 6:  To stop the sweeping, click on "Swp State" dialog box again to toggle it off. 
 
Exercise: Generate a square wave sweep from 1 kHz to 10 kHz with sweep time of 2s. 
 
 

HPE3631A DC Power Supply 
 
The HPE3631A is a high performance 80-Watt triple output DC power supply with HP-IB and RS-232 
interfaces, it has excellent load and line regulation and low ripple and noise, as well as the ability to store 
and recall instrument states. 
The operation of this power supply is fairly simple and straightforward.  The following example illustrates 
usage of the equipment. 
Example: In this example, we will set an output level for the 6 volts output terminal. 

Step 1:  Turn on the power supply; the power button is located at the lower left hand corner of the 
front panel. 

Step 2:  Press the "+6V" key, which is the first key from the left on the first row.  Now the screen 
should show the current output voltage of the 6-volt output. 

Step 3:  To change the output voltage, either use the big round knob or use the left and right arrow 
key on the right side of the front panel.  Set it to +5 volts. 
 
Exercise: Send -20 volts to the -25 volt output terminal. 
 
You can also store and recall the current instrument state using very similar procedures as for the 
HP33120A function generator. 
Another key you will frequently use is the "Output On/Off" key; this is to toggle all the outputs either on or 
off.  It is recommended that you turn off the outputs when making a change to your circuits. 
 

HP 54616C Oscilloscope 
 
Introduction: HP 54616C offers exceptional waveform viewing and measurements in a small, lightweight 
package.  This oscilloscopes give you: 1 ns peak detect; 2 GSa/s sample rate; 500 MHz bandwidth, and 1 
ns/div Main and Delayed time bases; Selectable input impedance; Protection of the internal 50 Ohm load; 
Horizontal and vertical pan and zoom; Color Display.  This oscilloscope is very easy to use because of their 
familiar controls and real time display. 
 
To connect a signal to the oscilloscope:  
The input impedance of this scope is selectable -- either 50 Ohm or 1 M-Ohm.  The 50-Ohm mode matches 
50-Ohm cables commonly used in making high frequency measurements.  The 1 M-Ohm mode is for use 
with probes and for general-purpose measurements. 
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• Use a cable or a probe to connect a signal to channel 1. 
• The oscilloscope has automatic probe sensing if you are using the probes supplied with the scope, or 

other probes with probe sensing. 
• If you are not using automatic probe sensing, then follow these next two steps. 
• To set the input impedance, press [1].  Select the desired Input impedance of 50 Ohm or 1 M-Ohm. 
• To set the probe attenuation factor press [1].  Select the Next Menu softkey.  Next toggle the Probe 

softkey to change the attenuation factor to match the probe you are using. 
1. Connect the 10:1 probe from channel 1 to the front-panel probe compensation signal on the 

oscilloscope. 
2. Press [Autoscale]. 
3. Use a nonmetallic tool to adjust the trimmer capacitor on the probe for the flattest pulse possible as 

displayed on the scope. 
 
To display a signal automatically: 
1. Connect a signal to the oscilloscope. 
2. Press [Autoscale]. 

When you press [Autoscale], the scope changes the front-panel setup to display the signal. 
However, if you pressed [Autoscale] unintentionally, you can use the Undo Autoscale 
Feature.  To use this feature, perform the following step 
• Press [Setup], and then press the Undo Autoscale softkey. 

The scope returns to the configuration in effect before you pressed [Autoscale]. 
 
To set up the vertical window: 
The following exercise guides you through the vertical keys, knobs, and status line. 
1. Center the signal on the display with the Position knob. 

The Position knob moves the signal vertically, and it is calibrated.  Notice that as you turn the Position 
knob, a voltage value is displayed for a short time indicating how far the ground reference is located 
from the center of the screen. 

2. Change the vertical setup and notice that each change affects the status line differently. 
You can quickly determine the vertical setup from the status line in the display. 
• Change the vertical sensitivity with the Volts/Div knob and notice that it causes the status line to 

change 
• Press [1].  A soft key menu appears on the display, and the channel turns on. 
• Toggle each of the softkeys and notice which keys cause the status line to change. 

Channels 1 and 2 have a vernier softkey that allows the Volt/Div knob to change the vertical step 
size in smaller increments.  These smaller increments are calibrated, which results in accurate 
measurements. 

• To turn the channel off, either press [1] a second time or press the left-most softkey. 
 
To set up the time base: 
The following exercise guides you through the time base keys, knobs, and status line. 
1. Turn the Time/Div knob and notice the change it makes to the status line. 
2. Change the horizontal setup and notice that each change affects the status line differently. 

• Press [Main/Delayed]. 
A softkey menu appears on the display with six softkey choices. 

• Toggle each of the softkeys and notice which keys causes the status line to change. 
• Turn the Delay knob and notice that its value is displayed in the status line. 

 
To trigger the oscilloscope: 
The following exercise guides you through the trigger keys, knobs, and status line. 
1. Turn the trigger Level Knob and notice the changes it makes to the display. 

As you turn the Level knob or press a trigger menu key, for a short time two things happen on the 
display.  First, the trigger level is displayed in inverse video.  If the trigger is de coupled, it is displayed 
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as a voltage.  If the trigger is ac coupled, it is displayed as a percentage of the trigger range.  Second, if 
the trigger source is turned on, a line is displayed showing the location of the trigger level. 

2. Change the trigger setup and notice that each change affects the status line differently. 
• Press [Source].  A softkey menu appears on the display showing the trigger source choices. 
• Toggle each of the softkeys and notice that each key causes the status line to change. 
• Press [External Trigger].  A softkey menu appears on the display showing the external trigger 

choices. 
• Press [Mode].  A softkey menu appears on the display with five trigger mode choices. 
• Toggle the Single and TV softkeys and notice that they affect the status line differently.  (You can 

only select TV if the trigger source is either channel 1 or 2.) 
When the scope is triggering properly, the trigger mode portion of the status line is blank. 

• Press [Slope/Coupling].  A softkey menu appears on the display.  If you selected Auto level, Auto, 
Normal, or Single as a trigger mode, six softkey choices are displayed. 

• Toggle each of the softkeys and notice which keys affect the status line. 
• External trigger input coupling (ac or dc) is selected from the External Trigger menu. 

3. Adjust the Holdoff knob and observe how it changes the display. 
Holdoff keeps the trigger from rearming for an amount of time that you set.  Holdoff is often used to 
stabilize the display of complex waveforms.  The Holdoff range is from 300.0 ns to about 13.5 s. 

 
To use pan and zoom: 
Pan means to move the acquired waveform horizontally or vertically.  Zoom means to expand or compress 
the acquired waveform horizontally or vertically.  Pan and zoom allows you to examine your captured 
waveform once the acquisition has been stopped. 
1. Press the [Stop] key. 
2. To pan horizontally, turn the Delay knob. 
3. To pan vertically, turn the Position knob. 
4. To zoom horizontally, turn the Time/Div knob. 
5. To zoom vertically, turn the Volts/Div knob. 

When you pan and zoom after the acquisition is stopped, the displayed waveform changes to reflect the 
data acquired by the last trigger. 

 
To use storage oscilloscope operation: 
There are four front-panel storage keys.  They are white instant action keys that change the operating mode 
of the oscilloscope.  The following steps demonstrate how to use these storage keys. 
1. Connect a signal to the scope and obtain a stable display. 
2. Press [Autostore].  Notice that STORE replaces RUN in the status line on the top line of the display. 

For easy viewing, the stored waveform is displayed in half bright and the most recent trace is displayed 
in full bright.  Autostore is useful in a number of applications. 
• Displaying the worst-case extremes of varying waveforms 
• Capturing and storing waveform 
• Measuring noise and jitter 
• Capturing events that occur infrequently 

3. Using the Position knob in the Vertical section of the front panel, move the trace up and down about 
one division. 
• To clear the display, press [Erase]. 
• To exit the Autostore mode, press either [Run] or [Autostore]. 

 
To make frequency measurements automatically: 
The automatic measurement capability of the scope makes frequency measurement easy, as the following 
steps demonstrate. 
1. Connect a signal to scope and obtain a stable display. 
2. Press [Time]. 
3. Toggle the Source softkey to select a channel for the frequency measurement. 
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4. Press the Freq softkey.  The scope measures the frequency and displays the result on the lower line of 
the display. 

 
To make time measurements automatically: 
You can measure the following parameters with the scope: frequency, period, duty cycle, width, rise time, 
and fall time. 
1. Connect a signal to scope and obtain a stable display. 
2. Press [Time].  A softkey menu appears with softkey choices.  3 of the softkeys are time measurement 

functions. 
3. Press the Next Menu softkey. 
4. Press the Rise Time softkey.  The scope measures the rise time of the signal and displays the result on 

the display. 
 
To make voltage measurements automatically: 
You can measure the following voltage parameters with the scope: peak-to-peak, average, rms, maximum, 
minimum, top, and base. 
 
1. Connect a signal to scope and obtain a stable display. 
2. Press [Voltage].  A softkey menu appears with six softkey choices.  3 of the softkeys are voltage 

measurement functions. 
Source Selects a channel for the voltage measurement 
Voltage Measurements Three voltage measurement choices are available: Vp-p, Vavg, and Vrms. 
Clear Meas erases any measurement results from the display. 

3. Press the Vrms softkey.  The scope measures the rms voltage and displays the result on the display 
4. Press the Next Menu softkey.  Another voltage measurement softkey menu appears. 
 
To use the XY display mode: 
The XY display mode converts the scope from a volts vs.  time display to a volts vs.  volts display.  This 
exercise shows a common use of the XY display mode by measuring the phase shift between two signals of 
the same frequency with the Lissajous method. 
1. Connect a signal to channel 1, and a signal of the same frequency but out of phase to channel 2. 
2. Press [Autoscale], press [Main/Delayed], then press the XY softkey. 
3. Center the signal on the display with the Position knobs, and use the Volts/Div knobs and the vertical 

Vernier softkeys to expand the signal for convenient viewing. 
4. Press [Cursors]. 
5. Set the Y2 cursor to the top of the signal, and set Y1 to the bottom of the signal. 
6. Move the Y1 and Y2 cursors to the center of the signal. 
7. Calculate the phase difference using formula below. 

Sin (theta) = (second change in y)/(first change in y) 
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Appendix C: Data Manipulation MS Excel 
 

This is a very simple overview of some of the basic features of Excel that you will be using.  A basic 
knowledge of navigation and cell manipulation is assumed.  For additional help on how to use Excel, use 
the Help feature. 
 
 
Using Formulas 
A formula for a cell is specified by using the = sign.  The formula can contain any standard mathematical 
functions and other more sophisticated functions. 
 
When a cell containing a formula is copied not the final value of the formula is copied, but the formula 
itself.   

 
Relative vs. Absolute referencing 
Relative references   When you create a formula, references to cells or ranges are usually based on their 
position relative to the cell that contains the formula. In the following example, cell B6 contains the formula 
=A5; Microsoft Excel finds the value one cell above and one cell to the left of B6. This is known as a 
relative reference. 

 

  
When you copy a formula that uses relative references, Excel automatically adjusts the references in the 
pasted formula to refer to different cells relative to the position of the formula. In the following example, 
the formula in cell B6, =A5, which is one cell above and to the left of B6, has been copied to cell B7. Excel 
has adjusted the formula in cell B7 to =A6, which refers to the cell that is one cell above and to the left of 
cell B7. 

 

  
Absolute references   If you don't want Excel to adjust references when you copy a formula to a different 
cell, use an absolute reference. For example, if your formula multiplies cell A5 with cell C1 (=A5*C1) and 
you copy the formula to another cell, Excel will adjust both references. You can create an absolute 
reference to cell C1 by placing a dollar sign ($) before the parts of the reference that do not change. To 
create an absolute reference to cell C1, for example, add dollar signs to the formula as follows:=A5*$C$1 

Column Addition Example (Double click on the table to view more detail) 

Column1 Column2 Result
10 0 10 <--This formula is =A3+B3
25 5 30 Copy of C3
3 89 92 Copy of C3

73 4 77 Copy of C3
22 7 29 Copy of C3
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Sample Plot 
Double click on the worksheet to view more detail 

X Y
1 0.8415
2 0.9093
3 0.1411
4 -0.7568
5 -0.9589
6 -0.2794
7 0.657
8 0.9894
9 0.4121

10 -0.544
11 -1
12 -0.5366
13 0.4202
14 0.9906

Sine Wave
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